• Réponses: 1 | Affichages: 2619
      Par Pitchoune (29/10/2008 - 02h40)
      Avatar de Pitchoune
      vBulletin Blog 2.0.0 Beta 4

      Il est l'heure de fournir une nouvelle version beta de Blog 2.0,cela devrait être la dernière version beta. Cette version contient des corrections de bugs pour les rapports signalés dans la version beta précédente. Nous recommandons à tous ceux utilisant Blog 2.0.0 Beta 3 de se mettre à jour afin de corriger des bugs.

      Les détails des fonctionnalitées et particularités incluent depuis la version 1.0 peuvent être trouvés dans mon annonce précédente ou dans mon blog.

      Remarque : vous devez utiliser vBulletin 3.7.3 ou supérieur pour installer Blog 2.0.0 Beta ! Blog 2.0.0 en version finale tournera avec vBulletin 3.7.4 minimum.

      Signification d'une version Beta
      Ceci est une version béta. Si vous sentez que vous arriverez pas à créer de sauvegardes ou de restauration, ou de vouloir effectuer de fréquentes mises à jour, n'installez pas cette version béta.

      Les licenciés doivent savoir que ceci est une version beta public, et non une version désignée comme étant « stable », ce qui nous amène à ses limitations :
      • Les versions Beta ne sont pas supportées officiellement. Vous pouvez l'utiliser à vos risques et périls.
      • Des erreurs connues subsistent dans cette version. Vous ne devez pas installer celle-ci sur des sites à forte affluence.
      • Des bugs majeurs non connus peuvent exister, si vous ne souhaitez pas être surpris par ces bugs, n'installez pas cette version beta.
      • Vous devez toujours sauvegarder l'intégralité de votre base de données avant d'installer les versions betas.
      • Si vous choisissez d'installer cette version, vous devez être conscient que de nouvelles versions vont sortir dès que des bugs ou failles auront été corrigés.

      A propos de vBulletin Blog

      vBulletin Blog est un système de blog qui permet à votre communauté de créer leur propre blog dans vBulletin. Donner aux membres un endroit pour laisser des idées et toute sorte d'autre chose donnera l'envie à vos utilisateurs de retourner sur votre communauté encore et encore, et un système d'administration avancé permet aux propriétaires des forums et modérateurs de garder le contrôle et d'intégrer le blog dans le système de vBulletin.

      vBulletin Blog permet simplement à votre communauté de créer leur propre espace dans la communauté. Son démarrage est aussi simple que son premier message (utilisant l'éditeur inclut dans vBulletin). Il n'y a pas de processus d'installation compliqué - les propriétaires de blog sont libres de personnaliser leur blog à n'importe quel moment en définissant un intitulé et description qui apparaîtront sur la page de chacune des entrées du propriétaire du blog.

      http://www.vbulletin.com/forum/showthread.php?t=289446
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 30 | Affichages: 11370
      Par Pitchoune (16/10/2008 - 17h48)
      Avatar de Pitchoune
      Comme beaucoup d'entre-vous le savez déjà, la quantité de spam sur les forums est en constante augmentation. Les outils pour outrepasser les systèmes CAPTCHA basés sur des images sont de plus en plus sophistiqués.

      Le développement de vBulletin tend à fournir de meilleurs outils pour combattre le spam pour vBulletin afin d'assister à prévenir toute forme de spam ainsi que de leur suppression (le tout sous forme automatique et assisté) mais ces outils ne sont pas encore prêts à être disponibles.

      Pour un futur proche, nous vous indiquons quelques recommandations. Notez que chaque recommandation est préfixé de la version de vBulletin requise minimum pour les appliquer.

      (3.6+) Ajouter de nouvelles images et polices pour le système de l'image de vérification

      Pour rendre le système de l'image de vérification plus efficace, vous pouvez rendre le système unique à votre site.

      Vous devrez créer dix images de 201 x 61 pixels au format JPEG. Les images devront être nommés de « background1.jpg » à « background10.jpg ». Elles doivent être placées dans le répertoire images/regimage/background de votre installation de vBulletin, écrasant les images déjà existantes.

      Vous pouvez aussi placer de nouvelles polices au format TrueType (.ttf) dans le répertoire images/regimage/fonts de votre installation de vBulletin, rendant la tâche plus difficile aux robots spammeurs de reconnaître le texte de vos images CAPTCHA. Les polices TrueType peuvent être téléchargés depuis un certain nombre de sites servant de librairie à polices.

      (3.7+) Utiliser en alternative la vérification humaine

      SI vous ne l'avez pas encore effectué, vous pouvez effectuer les étapes nécessaires pour utiliser le système reCAPTCHA disponible dans vBulletin 3.7. Ce système est extrêmement difficile pour les robots à contourner, car les mots présentés sont, de par leur nature, difficile à lire.

      Alternativement, si vous avez le temps nécessaire, vous pouvez utiliser le système de Vérification par des Questions et Réponses, aussi disponible dans vBulletin 3.7. Avec un nombre suffisant de questions et réponses fournies, ceci peut être un outil très efficace pour éviter les inscriptions des robots.

      hvoptions.png

      (3.7+) Activation de Akismet

      Le système anti-spam de vBulletin fourni par Akismet peut être efficace pour l'identification et la suppression de spam. Les propriétaires de licences vBulletin 3.7 peuvent activer ce système en s'inscrivant pour une clé Akismet, puis de visiter la partie de la Gestion du spam des Options vBulletin dans le Logiciel d'Administration.

      akismet.png

      (2.0+) Ajouter un champ du profil obligatoire lors de l'inscription

      Si votre site n'est pas directement visé, mais fait parti d'un groupe de sites qui se font attaquer, il peut être efficace d'ajouter un champ du profil lors de l'inscription. Cependant, si un humain se cache derrière la configuration du robot et analyse le formulaire d'inscription, ceci ne suffira pas.

      profilefield.png

      http://www.vbulletin.com/forum/showthread.php?t=288234
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 24 | Affichages: 8167
      Par Pitchoune (09/10/2008 - 15h06)
      Avatar de Pitchoune
      vBulletin 3.8.0 Beta 1

      Nous avons le plaisir d'annoncer la première version beta public de vBulletin 3.8.0, après avoir exécuté quelques versions alpha sur vBulletin.com, nous sommes satisfaits que les problèmes les plus sérieux soient résolus. Tout licencié avec une licence active peut télécharger la version beta.

      Il y a une page du blog étendue par Darren qui indique toutes les nouveautés et améliorations qui ont été effectuées pour vBulletin 3.8.0.

      Signification d'une version Beta
      Ceci est une version béta. Si vous sentez que vous arriverez pas à créer de sauvegardes ou de restauration, ou de vouloir effectuer de fréquentes mises à jour, n'installez pas cette version béta.

      Voici donc ses limitations :
      • Les versions Beta ne sont pas supportées officiellement. Vous pouvez l'utiliser à vos risques et périls
      • Des erreurs connues subsistent dans cette version. Vous ne devez pas installer celle-ci sur des sites à forte affluence.
      • Vous devez toujours sauvegarder l'intégralité de votre base de données avant d'installer les versions betas.
      • Si vous choisissez d'installer cette version, vous devez être conscient que de nouvelles versions vont sortir dès que des bugs ou failles auront été corrigés.
      • Impex ne prend pas en charge les versions betas. Il ne le fera que lors de la sortie de la version stable (3.8.0).

      http://www.vbulletin.com/forum/showthread.php?t=287460
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 0 | Affichages: 2304
      Par Pitchoune (07/10/2008 - 16h15)
      Avatar de Pitchoune
      vBulletin Blog 2.0.0 Beta 3

      Il est l'heure de fournir une nouvelle version beta de Blog 2.0. Cette version contient des corrections de bugs pour les rapports signalés dans la version beta précédente. Nous recommandons à toux ceux utilisant Blog 2.0.0 Beta 2 de se mettre à jour afin de corriger des bugs.

      Les détails des fonctionnalitées et particularités incluent depuis la version 1.0 peuvent être trouvés dans mon annonce précédente ou dans mon blog.

      Remarque : vous devez utiliser vBulletin 3.7.3 ou supérieur pour installer Blog 2.0.0 Beta ! Blog 2.0.0 en version finale tournera avec vBulletin 3.7.4 minimum.

      Signification d'une version Beta
      Ceci est une version béta. Si vous sentez que vous arriverez pas à créer de sauvegardes ou de restauration, ou de vouloir effectuer de fréquentes mises à jour, n'installez pas cette version béta.

      Les licenciés doivent savoir que ceci est une version beta public, et non une version désignée comme étant « stable w», ce qui nous amène à ses limitations :
      • Les versions Beta ne sont pas supportées officiellement. Vous pouvez l'utiliser à vos risques et périls.
      • Des erreurs connues subsistent dans cette version. Vous ne devez pas installer celle-ci sur des sites à forte affluence.
      • Des bugs majeurs non connus peuvent exister, si vous ne souhaitez pas être surpris par ces bugs, n'installez pas cette version beta.
      • Vous devez toujours sauvegarder l'intégralité de votre base de données avant d'installer les versions betas.
      • Si vous choisissez d'installer cette version, vous devez être conscient que de nouvelles versions vont sortir dès que des bugs ou failles auront été corrigés.

      A propos de vBulletin Blog

      vBulletin Blog est un système de blog qui permet à votre communauté de créer leur propre blog dans vBulletin. Donner aux membres un endroit pour laisser des idées et toute sorte d'autre chose donnera l'envie à vos utilisateurs de retourner sur votre communauté encore et encore, et un système d'administration avancé permet aux propriétaires des forums et modérateurs de garder le contrôle et d'intégrer le blog dans le système de vBulletin.

      vBulletin Blog permet simplement à votre communauté de créer leur propre espace dans la communauté. Son démarrage est aussi simple que son premier message (utilisant l'éditeur inclut dans vBulletin). Il n'y a pas de processus d'installation compliqué - les propriétaires de blog sont libres de personnaliser leur blog à n'importe quel moment en définissant un intitulé et description qui apparaîtront sur la page de chacune des entrées du propriétaire du blog.

      http://www.vbulletin.com/forum/showthread.php?t=287155

      L'annonce n'est pas visible en tant que nouvelle annonce car elle a été crée "avant" celle de la Beta 2 du à ce que ce soit l'annonce de la Beta 2 qui fut copié pour faire la Beta 3 (en conservant le jour et heure de l'annonce de la Beta 2 pour les 2 annonces)
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 5 | Affichages: 3078
      Par Pitchoune (03/10/2008 - 14h22)
      Avatar de Pitchoune
      vBulletin Blog 2.0.0 Beta 2

      Après avoir exécuté Blog 2.0.0 Beta 1 ici sur vBulletin.com depuis le mois dernier, nous sommes prêts à effectuer la première version beta publique. Tout licencié avec une licence Blog active peuvent télécharger cette version beta.

      Nous souhaitons remercier tous ceux qui nous ont fournit des suggestions ou signalé un bug pour le blog. La plupart des nouvelles spécificités dans cette version ont été ajoutées spécialement grâce à vos demandes. Nous sommes certain que vous aimerez ces améliorations. Nous n'avons cependant pas pu inclure toutes les demandes.

      Voici un aperçu de ces nouvelles fonctionnalitées :
      • Personnalisation du blog - les utilisateurs peuvent personnaliser leurs blogs de la même façon qu'ils peuvent personnaliser leurs profils (apparu avec vB 3.7).
      • Groupe de blogs - les utilisateurs peuvent avoir d'autres utilisateurs autorisés à écrire dans leurs blogs.
      • Barre latérale de blocs - les utilisateurs peuvent créer des blocs personnalisés à afficher dans la barre latérale. Ces blocs peuvent être arrangés par simple déplacement.
      • Pages personnalisées - les utilisateurs peuvent créer des pages personnalisées à afficher dans leur blog.
      • Tags - le support des tags a été inclut.
      • Gestionnaire d'entrées mises en valeur - plusieurs entrées peuvent maintenant êter mises en valeur sur la page d'accueil du blog.
      • Entrées privées - les utilisateurs peuvent définir les entrées à être privées tandis que leur blog est ouvert.
      • Catégories - les administrateurs peuvent maintenant définir des catégories.

      Il y a pas mal d'autres ajouts encore, vous pouvez trouver plus de détails sur mon blog.

      Remarque : vous devez utiliser vBulletin 3.7.3 ou supérieur pour installer Blog 2.0.0 Beta / Stable !

      Signification d'une version Beta
      Ceci est une version béta. Si vous sentez que vous arriverez pas à créer de sauvegardes ou de restauration, ou de vouloir effectuer de fréquentes mises à jour, n'installez pas cette version béta.

      Les licenciés doivent savoir que ceci est une version beta public, et non une version désignée comme étant « stable w», ce qui nous amène à ses limitations :
      • Les versions Beta ne sont pas supportées officiellement. Vous pouvez l'utiliser à vos risques et périls.
      • Des erreurs connues subsistent dans cette version. Vous ne devez pas installer celle-ci sur des sites à forte affluence.
      • Des bugs majeurs non connus peuvent exister, si vous ne souhaitez pas être surpris par ces bugs, n'installez pas cette version beta.
      • Vous devez toujours sauvegarder l'intégralité de votre base de données avant d'installer les versions betas.
      • Si vous choisissez d'installer cette version, vous devez être conscient que de nouvelles versions vont sortir dès que des bugs ou failles auront été corrigés.

      A propos de vBulletin Blog

      vBulletin Blog est un système de blog qui permet à votre communauté de créer leur propre blog dans vBulletin. Donner aux membres un endroit pour laisser des idées et toute sorte d'autre chose donnera l'envie à vos utilisateurs de retourner sur votre communauté encore et encore, et un système d'administration avancé permet aux propriétaires des forums et modérateurs de garder le contrôle et d'intégrer le blog dans le système de vBulletin.

      vBulletin Blog permet simplement à votre communauté de créer leur propre espace dans la communauté. Son démarrage est aussi simple que son premier message (utilisant l'éditeur inclut dans vBulletin). Il n'y a pas de processus d'installation compliqué - les propriétaires de blog sont libres de personnaliser leur blog à n'importe quel moment en définissant un intitulé et description qui apparaîtront sur la page de chacune des entrées du propriétaire du blog.

      http://www.vbulletin.com/forum/showthread.php?t=286707
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 3 | Affichages: 3409
      Par Pitchoune (30/09/2008 - 15h11)
      Avatar de Pitchoune
      vBulletin Project Tools 2.0.0

      Nous avons le plaisir d'annoncer et de rendre disponible la première version stable et supportée de Project Tools 2.0.x. Cette version est de suite disponible dans l'Espace Membres pour tous les licenciés avec une licence de Project Tools active.

      Project Tools 2.0.0 ajoute un certain nombre de nouvelles fonctionnalitées pour vous aider à organiser et rester au mieux dans vos projets. Les fonctionnalitées incluent :
      • Suivi d'étapes de projets
      • Abonnements aux projets
      • Notification lors d'assignations aux projets
      • Marquage persistant de lecture et indicateurs de nouveaux messages
      • Fermeture de rapport
      • Amélioration du suivi des rapports privés

      Vous pouvez en savoir plus dans mon annonce précédente ou sur mon blog.

      Remarque : vous devez utiliser vBulletin 3.7.0 ou supérieur pour installer Project Tools 2.0.0 !

      Mise à jour / Installation de Project Tools

      La mise à jour et l'installation de Project Tools suit le même processus : envoyez les fichiers et importez le fichier XML. Après cela, vous pourrez voir un message vous indiquant que la mise à jour / l'installation a été réussie. Pour une liste des instructions complète, veuillez vous rendre sur cette entrée du manuel.

      Modifications de templates

      Un grand nombre de templates ont été modifiées comparé à vBulletin Project Tools 1.0.x. Il est nécessaire de réinitialiser ces tesmplates ou sinon de bien intégrer les modifications dans les templates personnalisés ou les fonctions nouvelles et existantes ne fonctionneront pas. Une liste complète des templates à réinitialiser est disponible dans votre Logiciel d'Administration.

      Rapports de bugs

      Comme avec tout logiciel, des bugs peuvent apparaître. Si vous avez un soucis et que vous pensez que cela est un bug, ne l'indiquez pas sur les forums où les développeurs ne le verront jamais mais plutôt dans le bug tracker dédié pour créer un rapport qui sera suivi jusqu'à sa fin.

      Avant de signaler un bug, assurez-vous de le reproduire sur un forum utilisant un style par défaut non modifié et sans modifications (modules désactivés).

      À propos de Project Tools

      Project Tools est une extension versatile qui agrandit les fonctions de vBulletin en ajoutant un gestionnaire de projet, encourageant votre communauté d'utilisateurs à créer des projets, contribuer aux tâches, envoyer des rapports et voir la progression des projets. La simple intégration dans vBulletin assure une utilisation maximale, et lune suite administrative dans le Logiciel d'Administration de vBulletin permet une personnalisation complète des projets, rapports, tâches et permissions des utilisateurs.

      Project Tools est idéal pour toute communauté qui partage un but commun - par exemple le développement d'un logiciel, le suivi de serveurs, l'écriture de morceaux de musique, l'avancée d'un salon d'exposition ou même la construction de voitures !


      http://www.vbulletin.com/forum/showthread.php?t=286380
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 4 | Affichages: 3455
      Par Pitchoune (18/09/2008 - 23h30)
      Avatar de Pitchoune
      Comme vous auriez pu le remarquer si vous y passez souvent, les forums de vBulletin.com viennent de passer en version 3.8 afin d'avoir des premiers tests en production.

      Nous allons indiquer plus de détails le moment venu, mais pour le moment, nous souhaiterions avoir un retour des nouvelles fonctionnalités. Cela se passe surtout dans les discussions des groupes sociaux, navigation lightbox, le nouveau menu « Community »dans la barre de navigation, et bien plus !

      Enjoy

      http://www.vbulletin.com/forum/showthread.php?t=285273

      PS : l'annonce arrive avec un peu de retard, sachant qu'elle avait été remise en modération suite à un bug qui persistait dans les groupes de discussions.
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 0 | Affichages: 1956
      Par Pitchoune (10/09/2008 - 21h43)
      Avatar de Pitchoune
      vBulletin Project Tools 2.0.0 Release Candidate 1

      Cette version contient des corrections de bugs pour les rapports reportés dans les versions beta précédentes. Pour la plupart des cas, les rapports ne sont pas significatifs, ce qui fait que Project Tools passe en version Release Candidate. Si tout se passe correctement comme avec la dernière version beta, la prochaine version sera la version finale.

      Nous recommandons à toutes les personnes utilisant Project Tools 2.0.0 beta de se mettre à jour pour corriger les problèmes connus.

      Les méthodes d'installation / mise à jour standard s'appliquent ici.

      Remarque : vous devez utiliser vBulletin 3.7.0 ou supérieur pour pouvoir utiliser Project Tools 2.0.0 (Beta / Stable) !

      Signification d'une version Beta
      Ceci est une version béta. Si vous sentez que vous arriverez pas à créer de sauvegardes ou de restauration, ou de vouloir effectuer de fréquentes mises à jour, n'installez pas cette version béta.

      Les licenciés doivent savoir que ceci est une version beta public, et non une version désignée comme étant « stable w», ce qui nous amène à ses limitations :
      • Les versions Beta ne sont pas supportées officiellement. Vous pouvez l'utiliser à vos risques et périls.
      • Des erreurs connues subsistent dans cette version. Vous ne devez pas installer celle-ci sur des sites à forte affluence.
      • Vous devez toujours sauvegarder l'intégralité de votre base de données avant d'installer les versions betas.
      • Si vous choisissez d'installer cette version, vous devez être conscient que de nouvelles versions vont sortir dès que des bugs ou failles auront été corrigés.

      À propos de Project Tools

      Project Tools est une extension versatile qui agrandit les fonctions de vBulletin en ajoutant un gestionnaire de projet, encourageant votre communauté d'utilisateurs à créer des projets, contribuer aux tâches, envoyer des rapports et voir la progression des projets. La simple intégration dans vBulletin assure une utilisation maximale, et lune suite administrative dans le Logiciel d'Administration de vBulletin permet une personnalisation complète des projets, rapports, tâches et permissions des utilisateurs.

      http://www.vbulletin.com/forum/showthread.php?t=284522
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 18 | Affichages: 7005
      Par Pitchoune (04/09/2008 - 19h23)
      Avatar de Pitchoune
      vBulletin 3.7.3 PL1 / vBulletin 3.6.11 PL1

      Un rapport a été publié récemment pointant les failles potentielles dans le générateur aléatoire de nombre dans les applications PHP et qui peut révéler les nombre générés aléatoirement. Cette faille peut permettre aux chiffres aléatoires dans vBulletin d'être prédit et, selon certaines circonstances, permet à un attaquant d'obtenir l'accès à un compte utilisateur. Pour résoudre cette faille de sécurité, il est nécessaire de rendre disponible une version Patch Level (PL1) pour vBulletin 3.7.3 et vBulletin 3.6.11.

      Cette faille de sécurité a été découverte par Stefan Esser et son implication dans vBulletin.

      Le processus de mise à jour est le même que pour les versions PL précédentes - téléchargez simplement le patch depuis l'Espace Membres, extractez les fichiers et envoyez-les sur votre serveur web, en écrasant les fichiers déjà existants. Il n'y a aucun besoin d'un quelconque script de mise à jour.

      Comme toutes les versions de sécurité, nous recommandons à tous les licenciés de se mettre à jour aussi vite que possible afin d'éviter toute perte de données résultant de cette faille de sécurité.

      Mise à jour depuis 3.7.3 ou 3.6.11

      Si vous utilisez déjà 3.7.3 ou 3.6.11, le processus qui sera requis de suivre pour s'immuniser de la faille XSS est simple.

      Il n'y a pas besoin d'exécuter un script de mise à jour si vous êtes déjà en 3.7.3 ou 3.6.11.

      Veuillez vous rendre dans la partie Patchs de l'Espace Membres de vBulletin et téléchargez soit le patch pour 3.7.3 ou le patch pour 3.6.11, selon la version que vous utilisez actuellement, puis extractez les fichiers de l'archive téléchargé, transférez ces fichiers sur votre forum via FTP etc. en écrasant les fichiers déjà existants. Ceci mettra à jour votre version à la version PL correspondante.

      Mise à jour depuis une autre version que 3.7.3 ou 3.6.11

      Si vous n'utilisez pas encore les versions 3.7.3 ou 3.6.11, vous devez télécharger la dernière version actuelle dans l'Espace Membres et d'effectuer la mise à jour habituelle.

      Instructions entières sur la mise à jour de vBulletin.

      Téléchargement de vBulletin 3.7.3 PL1 ou 3.6.11 PL1

      Comme d'habitude, ces versions sont disponibles pour tous les licenciés avec une licence valide depuis l'Espace Membres.

      Espace Membres de vBulletin

      http://www.vbulletin.com/forum/showthread.php?t=283962
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 31 | Affichages: 10489
      Par Pitchoune (26/08/2008 - 14h12)
      Avatar de Pitchoune
      vBulletin 3.7.3

      Comme promis la semaine dernière, aujourd'hui voit la sortie de la version de maintenance pour vBulletin 3.7.x.

      vBulletin 3.7.3 contient un certain nombre de corrections de bugs, les détails de ces bugs peuvent être trouvés dans le bug tracker.

      Les corrections de sécurité incluent dans vBulletin 3.7.2 PL sont aussi incluent dans vBulletin 3.7.3.

      Mise à jour depuis une ancienne version

      vBulletin 3.7.3 est une version de maintenance et nous recommandons que tous les licenciés se mette à jour afin de bénéficier d'un grand nombre corrections de bugs ainsi que d'une meilleure stabilité.

      Veuillez lire les didacticiels concernés : Installation de vBulletin et Mise à jour de vBulletin.

      Configuration de PHP et MySQL

      vBulletin 3.7.3 demande au minimum PHP 4.3.3 et MySQL 4.0.16 ou supérieur.

      Toutefois, nous recommandons fortement à tous les licenciés d'utiliser PHP 5.2.6 avec APC (ou un autre système de cache PHP) et MySQL 5.0.67 ou supérieur. Des bénéfices de performances majeures peuvent être effectuées en suivant nos recommandations.

      Fin de vie pour PHP 4

      PHP 4 a atteint sa fin de vie avec PHP 4.4.9. Nous vous recommandons sérieusement de vous mettre à jour à la dernière version de PHP (5.2.6) ainsi que de MySQL (5.0.67). vBulletin 3.7.3 supporte ces produits sans le moindre problème, bien que vous puissiez devoir désactiver le mode stricte pour MySQL, voir ici sur comment activer l'option 'force_sql_mode'.

      Remarque : Nous continuerons à supporter PHP 4 pour les versions de vBulletin 3.x.x. Ce ne sera plus le cas pour vBulletin 4.

      Téléchargement de vBulletin 3.7.3

      Comme d'habitude, vBulletin 3.7.3 est disponible pour tous les licenciés avec une licence valide depuis l'Espace Membres.

      Espace Membres de vBulletin

      http://www.vbulletin.com/forum/showthread.php?t=282979
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 1 | Affichages: 2604
      Par Pitchoune (26/08/2008 - 14h07)
      Avatar de Pitchoune
      vBulletin 3.6.11

      Comme promis la semaine dernière, aujourd'hui voit la sortie de la version de maintenance pour vBulletin 3.6.x.

      vBulletin 3.6.11 contient un certain nombre de corrections de bugs, les détails de ces bugs peuvent être trouvés dans le bug tracker. De plus, une modification aété effectuée pour éviter que vos utilisateurs utilisent leur identifiant comme mot de passe. Voir ci-dessous pour plus d'informations.

      Les corrections de sécurité incluent dans vBulletin 3.6.10 PL sont aussi incluent dans vBulletin 3.6.11.

      Identifiant = Mot de passe interdit

      Dans cette version, les utilisateurs ne pourront plus définir leur identifiant et mot de passe en utilisant leur identifiant. Les utilisateurs qui utilisent leur identifiant comme mot de passe seront obligés de modifier leur mot de passe lors de leur prochaine connexion. De plus, un outil a été ajouté dans le Logiciel d'Administration pour envoyer un email aux utilisateurs affectés avec un nouveau mot de passe. Veuillez tenir compte de ces modifications lors de la mise à jour.

      Mise à jour depuis une ancienne version

      3.6.11 est une version de maintenance. nous recommandons que tous les licenciés utilisant une version antérieure de vBulletin 3.6 de se mettre à jour afin de bénéficier d'un grand nombre corrections de bugs ainsi que d'une meilleure stabilité.

      Veuillez lire les didacticiels concernés : Installation de vBulletin et Mise à jour de vBulletin.

      Configuration de PHP et MySQL

      Veuillez noter que vBulletin 3.6.x demande au minimum PHP 4.3.3 et MySQL 4.0.16 ou supérieur.

      Toutefois, nous recommandons fortement à tous les licenciés d'utiliser PHP 5.2.6 avec APC (ou un autre système de cache PHP) et MySQL 5.0.67 ou supérieur. Des bénéfices de performances majeures peuvent être effectuées en suivant nos recommandations.

      Fin de vie de PHP 4

      PHP 4 a atteint sa fin de vie avec PHP 4.4.9. Nous vous recommandons sérieusement de vous mettre à jour à la dernière version de PHP (5.2.6) ainsi que de MySQL (5.0.51). vBulletin 3.6.x supporte PHP 5 sans aucun problème, bien que vous puissiez devoir désactiver le mode stricte pour MySQL, voir ici sur comment activer l'option 'force_sql_mode'.

      Remarque : Nous continuerons à supporter PHP 4 pour les versions de vBulletin 3.x.x. Ce ne sera plus le cas pour vBulletin 4.

      Téléchargement de vBulletin 3.6.11

      Comme d'habitude, vBulletin 3.6.11 est disponible pour tous les licenciés avec une licence valide depuis l'Espace Membres.

      vBulletin Members Area

      http://www.vbulletin.com/forum/showthread.php?t=282976
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 6 | Affichages: 4771
      Par Pitchoune (18/08/2008 - 14h54)
      Avatar de Pitchoune
      vBulletin 3.7.2 PL2 / vBulletin 3.6.10 PL4

      Une faille de sécurité XSS affectant l'échappement des chaînes de caractères dans du code JavaScript a été identifié. Il permet à un attaquant d'effectuer des actions en tant qu'utilisateur ou d'obtenir un accès à des comptes des autres comptes utilisateurs. Pour résoudre cette faille de sécurité, il est nécessaire de rendre disponible une seconde version Patch Level (PL2) pour vBulletin 3.7.2 et une quatrième version Patch Level (PL4) pour vBulletin 3.6.10.

      Cette faille de sécurité a été découvert par Federico Muttis.

      Le processus de mise à jour est le même que pour les versions PL - téléchargez simplement le patch depuis l'Espace Membres, extractez les fichiers et envoyez-les sur votre serveur web, en écrasant les fichiers déjà existants. Il n'y a aucun besoin d'un quelconque script de mise à jour.

      Comme toutes les versions de sécurité, nous recommandons à tous les licenciés de se mettre à jour aussi vite que possible afin d'éviter toute perte de données résultant de cette faille de sécurité.

      Sortie de vBulletin 3.7.3 et 3.6.11 la semaine prochaine

      Selon notre nouvelle police de maintenance prévue, nous avons évalué les mérites de fournir une nouvelle version de maintenance un mois après la version précédente ou d'attendre le mois suivant. Il a été défini de vouloir rendre disponible vBulletin 3.7.3 et 3.6.11 le mardi 26 août 2008.

      Ces versions contiennent des corrections de bugs mais aussi corrigera le fait d'utiliser son identifiant comme mot de passe. Dans vBulletin 3.6.11 et 3.7.3, cette possibilité sera complètement désactivé. Les utilisateurs affectés par ceci devront modifier leur mot de passe lors de leur première connexion. De plus, un outil sera fourni pour envoyer un email aux utilisateurs affectés avec un nouveau mot de passe. Veuillez prendre en compte ces modifications de compatibilité lors de vos mises à jour.

      Ces versions sont mentionnées dans le bulletin de sécurité envoyé à nos licenciés aujourd'hui, mais nous ne fournirons pas de nouvelle notification la semaine prochaine quand vBulletin 3.7.3 et 3.6.11 seront disponibles. Regardez les nouvelles dans le Logiciel d'Administration ou la dernière version dans le Logiciel d'Administration pour voir quand cette version sera disponible. Alternativement, gardez un œil sur ce forum pour l'annonce de vBulletin 3.7.3 et 3.6.11.

      Mise à jour depuis 3.7.2, 3.6.10 ou leurs versions PL

      Si vous utilisez déjà 3.7.2, 3.6.10 ou leurs versions PL, le processus qui sera requis de suivre pour s'immuniser de la faille XSS est simple.

      Il n'y a pas besoin d'exécuter un script de mise à jour si vous êtes déjà en 3.7.2, 3.6.10 ou leurs versions PL.

      Veuillez vous rendre dans la partie Patchs de l'Espace Membres de vBulletin et téléchargez soit le patch pour 3.7.2 ou le patch pour 3.6.10, selon la version que vous utilisez actuellement, puis extractez les fichiers de l'archive téléchargé, transférez ces fichiers sur votre forum via FTP etc. en écrasant les fichiers déjà existants. Ceci mettra à jour votre version à la version PL correspondante.

      Le fichier patch pour vBulletin 3.7.2 PL2 contient le patch pour la version PL1. Cette chose est vraie aussi pour vBulletin 3.6.10 PL4.

      Mise à jour depuis une autre version que 3.7.2 ou 3.6.10

      Si vous n'utilisez pas encore les versions 3.7.2 ou 3.6.10, vous devez télécharger la dernière version actuelle dans l'Espace Membres et d'effectuer la mise à jour habituelle.

      Instructions entières sur la mise à jour de vBulletin.

      Téléchargement de vBulletin 3.7.2 PL2 ou 3.6.10 PL4

      Comme d'habitude, ces versions sont disponibles pour tous les licenciés avec une licence valide depuis l'Espace Membres.

      Espace Membres de vBulletin

      http://www.vbulletin.com/forum/showthread.php?t=282133
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 5 | Affichages: 8939
      Par Pitchoune (09/08/2008 - 15h17)
      Avatar de Pitchoune
      Annonce de développement de vBulletin

      Les choses n'ont jamais été aussi pressantes pour l'équipe de développement de vBulletin. La plupart de l'équipe travaille sur l'écriture des spécifications des nouvelles fonctions et de coder ces dernières et nous recherchons activement des personnes à embaucher pour nous assister dans cette tâche.

      Avec toute cette activité, il est temps maintenant de parler de ce qui se fait actuellement et ce qui va arriver bientôt.

      Project Tools 2.0, Blog 2.0
      La première chose que vous avez pu constater sont les nouvelles versions de Project Tools et Blog (les deux en version 2.0). Pour les personnes qui consultent le blog des développeurs ou le bug tracker en savent déjà quelque chose. La mise à jour de Project Tools est déjà active ici sous forme de version beta sur vBulletin.com et est disponible en téléchargement depuis l'Espace Membres. Blog 2.0 va arriver dans les semaines qui suivent.
      vBulletin 3.8
      Un peu plus tard cette année, vous aurez un premier aperçu de vBulletin 3.8 sur vBulletin.com. Tandis que nos efforts vont avant tout pour vBulletin 4, nous estimons qu'il y a encore quelques possibilitées avec la branche de vBulletin 3.x, ce qui fait que vBulletin 3.8 apportera de nouvelles fonctions, crées pour étendre et améliorer les fonctionnalités introduites dans vBulletin 3.7, tandis que l'ajout de certains gadgets feront surement plaisir à pas mal de monde en attendant vBulletin 4.

      Nous indiquerons plus d'informations à propos de vBulletin 3.8 dans les prochaines semaines, mais voici en attendant un petit aperçu :

      Discussions dans les groupes sociaux
      Ceci est probablement la fonction la plus demandée depuis l'introduction des groupes sociaux dans vBulletin 3.7. Tandis que le système de messages dans les groupes sociaux actuels permet de laisser des messages dans un groupe social, différemment des forums qui ne permet pas de diviser ces messages en plusieurs discussions. vBulletin 3.8 rectifie cela, et les groupes sociaux dans 3.8 auront la possibilité d'avoir des discussions individuelles, chacun avec leurs outils de signalement, modération intégrée et beaucoup d'autres outils espérés dans vBulletin.

      Améliorations de la messagerie privée
      Depuis vBulletin 3.0, le système de messagerie privée a été laissé comme tel. vBulletin 3.8 voit un certain nombre de modifications et d'améliorations pour rendre le système facile à utiliser et à gérer.

      Nous avons ajoutés la réponse rapide aux messages privés, supprimant la possibilité de visiter une interface séparée.
      Les utilisateurs ont maintenant la possibilité de modifier l'ordre de tri dans les dossiers des messages privés de l'actuel « Messages plus récents en premier ».
      Afin de rendre le système plus facile à utiliser, une recherche intégrée a été ajoutée par la même occasion.

      Aussi, en tant que mesure anti-spam, il est maintenant possible de limiter le nombre de messages privés à tout utilisateur pour une certaine période de temps.

      Albums les plus mis à jour
      Afin de sortir les fonctions d'albums au grand jour, vBulletin 3.8 a un système pour afficher les albums les plus fréquemment mis à jour dans une interface unifiée. Maintenant, tous vos utilisateurs sauront quand les envois d'images de vos membres seront effectuées !

      Déplacement des images des albums
      Il est maintenant possible de déplacer les images d'un album vers un autre, sans devoir supprimer et envoyer de nouveau.

      Permissions des préfixes de discussion
      Pour ceux qui souhaiteraient limiter l'accès aux utilisateurs d'utiliser les préfixes de discussion, vBulletin 3.8 vous permet de faire cela.

      Catégories de groupes sociaux
      Pour permettre aux utilisateurs de mieux retrouver un groupe social qu'ils souhaitent rejoindre, l'administrateur peut maintenant créer des catégories auquels les groupes sociaux peuvent appartenir.

      Avatars des groupes sociaux
      Une image peut résumer pleins de mots, quand les utilisateurs créeront un groupe social, ils peuvent maintenant envoyer une image représentant le groupe, qui sera visible dans le groupe et dans la liste des groupes.

      Il y a encore pleins de choses à raconter, et Darren pourra vous en toucher 2 mots afin d'indiquer les nouvelles fonctionnalités plus en détail dans un futur proche. Nous espèrerons sortir vBulletin 3.8 pour le quatrième trimestre 2008.

      vBulletin 3.8 aura la même configuration serveur que vBulletin 3.7.
      vBulletin 4.0
      La grosse nouveauté. vBulletin 4.0 est en cours de développement et est notre projet majeur. Certains ont pu remarquer qu'Andy Huang a été intégré dans l'équipe des développeurs pour nous aider avec les bugs et permettre à Mike et Scott de dépenser plus de temps aux nouveaux développements.

      vBulletin 4 est une réécriture étendue du système vBulletin, visant à donner une expérience supplémentaire pour les utilisateurs et administrateurs, tandis que nous fournirons des fonctionnalités et produits vB4 avec un code plus flexible et plus stable.

      Les utilisateurs bénéficieront d'une nouvelle interface intuitive pour fournir une plus grande accessibilité à travers un design propre et moderne. Les administrateurs découvriront aussi la puissance de la nouvelle gestion des templates XHTML, auquel la mise en page peut être redessiné et modifié avec les classes CSS.

      Du côté de l'architecture, vBulletin 4 suit le modèle des principes orienté objet MVC (model-view-controller), permettant une plus grande compatibilité dans la réutilisation et l'étendue possible du code. Il y aura une plus grande extensivité du cache et sera dessiné pour être utilisable selon un niveau jamais atteint encore par vBulletin.

      Du à la nature du nouveau code, nous travaillons beaucoup avec la communauté des développeurs de modules pour fournir des informations et de l'aide à propos des modifications actuelles pour vBulletin 4, pour qu'il y ait une bibliothèque de modules prête à être utilisée lors de son lancement.

      vBulletin 4 utilisera PHP 5.2.3 et MySQL 5.0.22 ou plus récents de chaque. Ceux utilisant APC et Memcache auront un avantage pour vBulletin 4.

      Nous vous tenons informés à propos des nouvelles fonctionnalités de vBulletin 4 dans les mois à venir.
      http://www.vbulletin.com/forum/showthread.php?t=280752
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 0 | Affichages: 1834
      Par Pitchoune (09/08/2008 - 14h26)
      Avatar de Pitchoune
      vBulletin Project Tools 2.0.0 Beta 2

      C'est l'heure d'une nouvelle version de Project Tools 2. Cette version corrige des bugs pour les rapports signalés pour la version beta précédente. Nous recommandons à toute personne utilisant Project Tools 2.0.0 Beta 1 de se mettre à jour afin de corriger les bugs connus.

      Les méthodes d'installation / mise à jour standard s'appliquent ici.

      Remarque : vous devez utiliser vBulletin 3.7.0 ou supérieur pour pouvoir utiliser Project Tools 2.0.0 (Beta / Stable) !

      Signification d'une version Beta
      Ceci est une version béta. Si vous sentez que vous arriverez pas à créer de sauvegardes ou de restauration, ou de vouloir effectuer de fréquentes mises à jour, n'installez pas cette version béta.

      Les licenciés doivent savoir que ceci est une version beta public, et non une version désignée comme étant « stable w», ce qui nous amène à ses limitations :
      • Les versions Beta ne sont pas supportées officiellement. Vous pouvez l'utiliser à vos risques et périls.
      • Des erreurs connues subsistent dans cette version. Vous ne devez pas installer celle-ci sur des sites à forte affluence.
      • Vous devez toujours sauvegarder l'intégralité de votre base de données avant d'installer les versions betas.
      • Si vous choisissez d'installer cette version, vous devez être conscient que de nouvelles versions vont sortir dès que des bugs ou failles auront été corrigés.


      À propos de Project Tools

      Project Tools est une extension versatile qui agrandit les fonctions de vBulletin en ajoutant un gestionnaire de projet, encourageant votre communauté d'utilisateurs à créer des projets, contribuer aux tâches, envoyer des rapports et voir la progression des projets. La simple intégration dans vBulletin assure une utilisation maximale, et lune suite administrative dans le Logiciel d'Administration de vBulletin permet une personnalisation complète des projets, rapports, tâches et permissions des utilisateurs.

      http://www.vbulletin.com/forum/showthread.php?t=280839

      PS : vive les annonces quand on est en vacances sans la moindre borne wifi...
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 6 | Affichages: 3220
      Par Pitchoune (17/07/2008 - 15h18)
      Avatar de Pitchoune
      vBulletin Project Tools 2.0.0 Beta 1

      Après avoir utilisé Project Tools 2.0.0 Alpha 1 sur vBulletin.com le mois dernier, nous sommes prêts à rendre disponible la première version beta public. Tout licencié ayant une licence active de Project Tools peut maintenant télécharger cette version.

      Nous souhaitons remercier tout ceux qui nous ont fournis leurs suggestions, retour d'utilisation ou reporté un/des bug(s) pour Project Tools. La plupart des nouvelles fonctions dans cette version ont été ajoutés spécialement selon vos demandes. Nous sommes certains que vous allez aimer nos ajouts.

      Voici une petite liste des ajouts de fonctionnalités dans Project Tools 2 :
      • Abonnements aux projets
      • Notification des assignements aux rapports
      • Marqueurs permanents de lecture / nouveaux indicateurs de rapports
      • Fermeture des rapports
      • Amélioration du suivi des rapports privés et de leurs réponses
      • Suivi d'étapes

      Vous pouvez en savoir plus dans ma précédente annonce ou dans mon blog.

      Remarque : vous devez utiliser vBulletin 3.7.0 ou supérieur pour pouvoir utiliser Project Tools 2.0.0 (Beta / Stable) !

      Signification d'une version Beta
      Ceci est une version béta. Si vous sentez que vous arriverez pas à créer de sauvegardes ou de restauration, ou de vouloir effectuer de fréquentes mises à jour, n'installez pas cette version béta.

      Les licenciés doivent savoir que ceci est une version beta public, et non une version désignée comme étant « stable w», ce qui nous amène à ses limitations :
      • Les versions Beta ne sont pas supportées officiellement. Vous pouvez l'utiliser à vos risques et périls.
      • Des erreurs connues subsistent dans cette version. Vous ne devez pas installer celle-ci sur des sites à forte affluence.
      • Vous devez toujours sauvegarder l'intégralité de votre base de données avant d'installer les versions betas.
      • Si vous choisissez d'installer cette version, vous devez être conscient que de nouvelles versions vont sortir dès que des bugs ou failles auront été corrigés.


      À propos de Project Tools

      Project Tools est une extension versatile qui agrandit les fonctions de vBulletin en ajoutant un gestionnaire de projet, encourageant votre communauté d'utilisateurs à créer des projets, contribuer aux tâches, envoyer des rapports et voir la progression des projets. La simple intégration dans vBulletin assure une utilisation maximale, et lune suite administrative dans le Logiciel d'Administration de vBulletin permet une personnalisation complète des projets, rapports, tâches et permissions des utilisateurs.

      http://www.vbulletin.com/forum/showthread.php?t=279007
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 1 | Affichages: 2581
      Par Pitchoune (08/07/2008 - 02h24)
      Avatar de Pitchoune
      vBulletin 3.7.2 PL1 / vBulletin 3.6.10 PL3

      Une faille de sécurité XSS affectant le système de connexion de vBulletin a été identifié, une seconde faille fut aussi trouvée affectant les forums en mode debug. Ceci permet à un attaquant de faire effectuer à un administrateur des actions non sollicitées dans le logiciel d'administration sans qu'elles ne soient souhaitées à la base. Pour résoudre ce problème, il est nécessaire de rendre disponible un patch pour vBulletin 3.7.2 et 3.6.10.

      ne des failles XSS a été découverte par Jessica Hope et d'autres personnes.

      Le processus de mise à jour est le même que pour les autres patchs - téléchargez simplement le patch depuis l'Espace Membres, extractez les fichiers et envoyez-les sur votre serveur web, en écrasant les fichiers déjà existants. Il n'y a aucun besoin d'un quelconque script de mise à jour.

      Comme toutes les versions de sécurité, nous recommandons à tous les licenciés de se mettre à jour aussi vite que possible afin d'éviter toute perte de données résultant de cette faille de sécurité.


      Mise à jour depuis 3.7.2, 3.6.10 ou de leurs versions PLx

      Si vous utilisez déjà 3.7.2, 3.6.10 ou leurs versions PLx, le processus qui sera requis de suivre pour s'immuniser de la faille XSS est simple.

      Il n'y a pas besoin d'exécuter un script de mise à jour si vous êtes déjà en 3.7.2, 3.6.10 ou leurs versions PLx.

      Veuillez vous rendre dans la partie Patchs de l'Espace Membres de vBulletin et téléchargez soit le patch pour 3.7.2 ou le patch pour 3.6.10, selon la version que vous utilisez actuellement, puis extractez les fichiers de l'archive téléchargé, transférez ces fichiers sur votre forum via FTP etc. en écrasant les fichiers déjà existants. Ceci mettra à jour votre version à la version PL1 pour vBulletin 3.7.2 et à la version PL3 pour vBulletin 3.6.10.

      Le fichier patch pour vBulletin 3.6.10 PL3 contient le patch pour la version PL1 et PL2.


      Mise à jour depuis une autre version que 3.7.2 ou 3.6.10

      Si vous n'utilisez pas encore les versions 3.7.2 ou 3.6.10, vous devez télécharger la dernière version actuelle dans l'Espace Membres et d'effectuer la mise à jour habituelle.

      Instructions entières sur la mise à jour de vBulletin.

      Téléchargement de vBulletin 3.7.2 PL1 ou 3.6.10 PL3

      Comme d'habitude, ces versions sont disponibles pour tous les licenciés avec une licence valide depuis l'Espace Membres.

      Espace Membres de vBulletin

      http://www.vbulletin.com/forum/showthread.php?t=277945

      PS : pas besoin de nous indiquer que c'est sorti, on sait lire, merci !
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 35 | Affichages: 10303
      Par Pitchoune (24/06/2008 - 16h12)
      Avatar de Pitchoune
      vBulletin 3.7.2

      Comme promis la semaine dernière, aujourd'hui voit la sortie de la version de maintenance pour vBulletin 3.7.x.

      vBulletin 3.7.2 contient un certain nombre de corrections de bugs, les détails de ces bugs peuvent être trouvés dans le bug tracker.

      Les corrections de sécurité incluent dans vBulletin 3.7.1 PL1 et PL2 sont aussi incluent dans vBulletin 3.7.2.

      Mise à jour depuis une ancienne version

      vBulletin 3.7.2 est une version de maintenance et nous recommandons que tous les licenciés se mette à jour afin de bénéficier d'un grand nombre corrections de bugs ainsi que d'une meilleure stabilité.

      Veuillez lire les didacticiels concernés : Installation de vBulletin et Mise à jour de vBulletin.


      Configuration de PHP et MySQL

      vBulletin 3.7.2 demande au minimum PHP 4.3.3 et MySQL 4.0.16 ou supérieur.

      Toutefois, nous recommandons fortement à tous les licenciés d'utiliser PHP 5.2.6 avec APC (ou un autre système de cache PHP) et MySQL 5.0.51 ou supérieur. Des bénéfices de performances majeures peuvent être effectuées en suivant nos recommandations.

      Fin de vie pour PHP 4 annoncé

      Le groupe PHP a annoncé la fin de vie de PHP 4. Nous vous recommandons sérieusement de vous mettre à jour à la dernière version de PHP (5.2.6) ainsi que de MySQL (5.0.51). vBulletin 3.7.2 supporte ces produits sans le moindre problème, bien que vous puissiez devoir désactiver le mode stricte pour MySQL, voir ici sur comment activer l'option 'force_sql_mode'.

      Remarque : Nous continuerons à supporter PHP 4 pour les versions de vBulletin 3.x.x. Ce ne sera plus le cas pour vBulletin 4.

      Téléchargement de vBulletin 3.7.2

      Comme d'habitude, vBulletin 3.7.2 est disponible pour tous les licenciés avec une licence valide depuis l'Espace Membres.

      Espace Membres de vBulletin

      http://www.vbulletin.com/forum/showthread.php?t=276496
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 4 | Affichages: 3441
      Par Pitchoune (18/06/2008 - 19h34)
      Avatar de Pitchoune
      vBulletin 3.7.1 PL2 / vBulletin 3.6.10 PL2

      Une faille de sécurité XSS affectant le système de redirection de vBulletin a été identifié. Il permet à un attaquant de tromper un modérateur ou administrateur dans une action de manière inconsciente dans la partie publique ou le Logiciel d'Administration / de Modération et qui n'est pas souhaitée. Pour résoudre cette faille de sécurité, il est nécessaire de rendre disponible une seconde version Patch Level (PL2) pour vBulletin 3.7.1 et 3.6.10.

      Bien qu'il soit difficile à exploiter la faille XSS et que cette faille est très limité, nous recommandons toutefois à tous les licenciés de se mettre à jour.

      Cette faille de sécurité XSS, et ce qui a rendu nécessaire de rendre disponible les versions PL1 nécessaire, a été découvert par Jessica Hope et d'autres personnes.

      Le processus de mise à jour est le même que pour les versions PL1 - téléchargez simplement le patch depuis l'Espace Membres, extractez les fichiers et envoyez-les sur votre serveur web, en écrasant les fichiers déjà existants. Il n'y a aucun besoin d'un quelconque script de mise à jour.

      Comme toutes les versions de sécurité, nous recommandons à tous les licenciés de se mettre à jour aussi vite que possible afin d'éviter toute perte de données résultant de cette faille de sécurité.

      Sortie de vBulletin 3.7.2 la semaine prochaine

      Selon notre nouvelle police de maintenance prévue, nous avons évalué les mérites de fournir une nouvelle version de maintenance un mois après la version précédente ou d'attendre le mois suivant. Il a été défini de vouloir rendre disponible vBulletin 3.7.2 de mardi 29 juillet au mardi 24 juin.

      Cette version est mentionnée dans le bulletin de sécurité envoyé à nos licenciés aujourd'hui, mais nous ne fournirons pas de nouvelle notification la semaine prochaine quand vBulletin 3.7.2 sera disponible. Regardez les nouvelles dans le Logiciel d'Administration ou la dernière version dans le Logiciel d'Administration pour voir quand cette version sera disponible. Alternativement, gardez un œil sur ce forum pour l'annonce de vBulletin 3.7.2.

      Pour résumer, vBulletin 3.7.2 sera disponible le mardi 24 juin 2008.

      Mise à jour depuis 3.7.1, 3.6.10 ou leurs versions PL1

      Si vous utilisez déjà 3.7.1, 3.6.10 ou leurs versions PL1, le processus qui sera requis de suivre pour s'immuniser de la faille XSS est simple.

      Il n'y a pas besoin d'exécuter un script de mise à jour si vous êtes déjà en 3.7.1,3.6.10 ou leurs versions PL1.

      Veuillez vous rendre dans la partie Patchs de l'Espace Membres de vBulletin et téléchargez soit le patch pour 3.7.1 ou le patch pour 3.6.10, selon la version que vous utilisez actuellement, puis extractez les fichiers de l'archive téléchargé, transférez ces fichiers sur votre forum via FTP etc. en écrasant les fichiers déjà existants. Ceci mettra à jour votre version à la version PL2.

      Le fichier patch pour vBulletin 3.7.1 PL2 contient le patch pour la version PL1. Cette chose est vraie aussi pour vBulletin 3.6.10 PL2.

      Mise à jour depuis une autre version que 3.7.1 ou 3.6.10

      Si vous n'utilisez pas encore les versions 3.7.1 ou 3.6.10, vous devez télécharger la dernière version actuelle dans l'Espace Membres et d'effectuer la mise à jour habituelle.

      Instructions entières sur la mise à jour de vBulletin.

      Téléchargement de vBulletin 3.7.1 PL2 ou 3.6.10 PL2

      Comme d'habitude, ces versions sont disponibles pour tous les licenciés avec une licence valide depuis l'Espace Membres.

      Espace Membres de vBulletin

      http://www.vbulletin.com/forum/showthread.php?t=275889
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 0 | Affichages: 2573
      Par Pitchoune (11/06/2008 - 17h57)
      Avatar de Pitchoune
      Comme pour vBulletin Blog, l'extension vBulletin Project Tools connaitra aussi une mise à jour dans un futur proche. Nous avons reçu de grands retours d'utilisation que vous souhaitez avoir dans Project Tools, que ce soit dans l'amérioration de la gestion des projets ou dans la meilleure intégration avec les fonctionnalités du forum.

      Cette version de Project Tools à venir vise à implanter la plupart des fonctionnalités les plus populaires qui nous a été demandé. Voici une rapide liste de ce qui a été demandé :

      Abonnements aux projets
      Les utilisateurs peuvent maintenant s'abonner à des types de rapports individuels (bug, fonctionnalité, tâche) dans un projet et d'obtenir un résumé sur les derniers changements, comme les abonnements des forums.

      Notification sur les assignements des rapports
      Si un utilisateur est assigné à un rapport par quelqu'un d'autre, il lui sera envoyé un email à propos de l'assignement.

      Marquer comme lus les rapports / nouveaux indicateurs de messages
      Une fonctionnalité standard des forums, Project Tools indique maintenant quels rapports vous avez lus et ceux qui ont de nouveaux rapports. Voici quelques fonctions qui y seront liés :
      • Intitulés des rapports en gras
      • Liens "Aller vers..."
      • Les icônes des projets qui indiquent de nouveaux contenus
      • Les compteurs des types de rapports qui indiquent le nouveau contenu spécifiquement pour ce type
      • Affichage amélioré des rapports non lus dans le Tableau de bord
      • Liens "Trouver les nouveaux rapports"


      Fermeture des rapports
      Une fonctionnalité plutôt simple, mais les rapports qui n'ont plus lieu d'être peuvent être fermés. Comme dans les forums, ceci évite d'avoir des réponses aux rapports exceptés de ceux qui ont ouvert le rapport. Ceci bloque aussi les méta données du rapport jusqu'à ce que le rapport soit de nouveau ouvert.

      Meilleur suivi des rapports/réponses privés
      Précédemment, si quelqu'un répondait de manière privé à un rapport, ceci ne modifiait pas les informations de dernière réponse, ce qui permet de louper le message très facilement. Maintenant, les réponses privées changeront l'heure de la dernière réponse et le compteur de réponses (si vous pouvez voir le message privée). De cette façon, vous ne loupez rien.

      Ceci n'est pas une liste complète, comme vous pouvez vous en douter. Pour cela, vous devrez aller jeter un coup d'œil dans le blog des développeurs de vBulletin.



      Oh, encore une chose... Vous pouvez espérer voir cette future version de Project Tools ici ce mois-ci. Les versions bétas seront disponibles à ceux qui ont acheté Project Tools le mois prochain (Juillet).

      http://www.vbulletin.com/forum/showthread.php?t=275125
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Réponses: 1 | Affichages: 2966
      Par Pitchoune (09/06/2008 - 21h12)
      Avatar de Pitchoune
      Depuis sa sortie initiale, vBulletin Blog a prouvé de par lui-même être une extension de vBulletin populaire. Il a été bien reçu et vendu à beaucoup de monde.

      Bien sûr, aucun software est parfait, et nous avons apprécié le retour d'utilisation de la part des licenciés à propos des fonctionnalités existantes ainsi que des fonctionnalités souhaitées.

      Toutefois, nous avons le plaisir d'annoncer qu'une version signifiante de vBulletin Blog est en cours de développement, qui proposera des nouvelles fonctionnalités et d'implanter la plupart des suggestions pour améliorer les fonctionnalités existantes.

      Rien n'a été oublié en tant que suggestion de fonctionnalités ou de modifications de fonctionnalités effectués dans le forum des suggestions. Cette mise à jour est prévue d'être disponible dans un futur proche, le pire de ne e trouve dans la liste des fonctionnalités mais ce qui s'y trouve sera largement suffisant afin de plaire à tout le monde tandis que les versions vont arriver en un temps correct entre chaque version.

      Voici une courte liste des nouvelles fonctionnalités pour vBulletin Blog.

      Tags
      Que serait un blog sans les tags ? Nous voulions vraiment permettre l'utilisation des tags dans vBulletin Blog 1.0 mais nous en avions pas eu le temps. Les tags auront un nuage de tags général (pour tous les blogs) et au niveau de chaque blog.

      Entrées mises en valeur
      Les licenciés ont demandés à avoir plus de possibilitées avec la fonction « Entrées mises en valeur ». Maintenant, vous pourrez sélectionner plusieurs entrées à partir d'un certain nombre de critères.

      Blocs des blogs
      Vos utilisateurs seront capable de créer leurs propres blocs personnalisés pour les faire apparaître dans la barre sur le côté. Ils seront capable de définir un ordre d'affichage entre tous les blocs.

      Catégories
      En tant qu'administrateur, vous pouvez créer des catégories qui sont accessibles à tous les utilisateurs ou qui peuvent être limités à des groupes d'utilisateurs spécifiques.

      Personnalisation du Blog
      Une des fonctionnalités les plus demandées est la possibilité de personnaliser leur blog. Comme les utilisateurs peuvent modifier leur profil dans vBulletin 3.7, les personnalisations seront aussi intégrées dans le blog.

      Autres fonctionnalités de vBulletin 3.7
      vBulletin 3.7 a introduit de nouvelles fonctionnalités qui seront applicables au blog.
      • La fonction « lightbox » est maintenant utilisée dans le blog.
      • Les liens sociaux ont été implantés pour chaque entrée.
      • La modification rapide et la réponse rapide ont aussi été intégrés.

      Bien sûr, ce n'est pas une liste complète - nous voudrions pas tout vous dévoiler avant d'avoir l'archive en main.

      Nous espérons pouvoir nous fournir des informations supplémentaires en temps voulu à propos de vBulletin Blog via le blog des développeurs de vBulletin.

      http://www.vbulletin.com/forum/showthread.php?t=274922
      Répondre Afficher une version imprimable Envoyer un lien vers cette page par email
    • Page 8 sur 22 PremièrePremière ... 4 5 6 7 8 9 10 11 12 18 ... DernièreDernière